How to debug? Machine freezing when laser starts


Is there a way to debug/troubleshoot the FabCore? E.g. getting logs, starting a trace,…? Anything to understand where it goes wrong (and then fix it)?

I have this long-time issue when you start a job (via LightBurn or via FabCore), it goes to the origin and then it stops, everything is blocked.
Workaround is fairly simple, press the reset button and try again. Focus on try, as it might get stuck again (or it might just perform the job).

This is unrelated to the job, it can happen to simple and complex drawings. Yesterday it took me 5 min to cut a simple (test)square.

Any help is appreciated :slight_smile:

Hmmm. Never heared that one before. Are you using absolute or relative (user origin) coordinates in your job?
When starting a job from the FabCore controller, i always press its Origin button to make sure the current position is the origin.

I always use absolute coordinates
I always try to move my drawing as close to x=0; y=0, simply because I prefer the origin button on the FabCore.

Are you engraving? Then it could be that your running out side of the axis movement area.

Are you familiar with how overscan works? It’s meant to mitigate the overburning of the start/end of an engraving scan line due to delays associated with the acceleration and deceleration of the laser head. It does this by allowing the laser head motion to start before the actual burn start point and end after it.

It seems unrelated to the type of job, big or small, simple or complex, it can happen with any 1 of them.

Last job was a simple small 1x1cm square that I wanted to cut. Probably had to reset the machine 15 times, set the origin on different points, uploaded different job-filed (same square). Nothing worked, then just at random, it does work.

Hi Robin,

Can you send a video of what is going one to Or post it here?

Kind regards,

@Robin does it occur with the laser power disabled?

Hi all, [FabCreator Crafty]

I have very similar issue and video is here

Job exported from Lightburn, run job, then it freezes the laser and needs to be reset. It did some of the previous jobs just fine.

Check it out and let me know if you have any news about that

Same questions does it occur with the laser power disabled? It can be a sign of a faulty PSU, in your case the strange part is we had now issues with this device and it was an ex demo crafty with a fair few hours.

Try pulsing the laser before running the job.
Try restarting the machine.
Try disabling the laser, run the job and then turn on the laser. (Keyswitch)

How many devices do you have pluged into the same power circuit, while the lasers dont use alot of power on average they do peak. This peak can create a drop in voltage and upset the controller. Try running the laser on a power circuit with less devices.

Kind regards,

Laser plugged to a socket with just a smartphone charger. Other devices in the heavy-duty extension cord.

    • pulsing before the job HELPS
    • restarting does not help
    • with keyswitch ON > you need to pulse before job | with keyswitch OFF > works

In order to make it work PULSE before job, but that is not a solution.

Any other ideas? Thank you

Indeed not a solution if you have to keep doing it!

What power are you trying to run the job at?
Does it run with lower powers?

With regards to the socket, are they seperate circuits as in on a different fuse group.
The filter for example can draw up to 12.5amps.

Typically the way to fix this is to replace the PSU,

Do you have any UPS? Uninterruptible power supplies?

After a few attempts:
with 100% power > freeze

After cutting and testing for some time (2 hours)
with 100% power > no problem

Now it runs anything, next week I will try it again what will happen right from the start.

idk, it is an university architectural studio class - should withstand the load with no other machines

I do not have any UPS.

I got the same problem with freezing newly on my FabCore. Never got this problem before during almost 4 years of use.

I also had problems with wrong cuttings, which I never had before. This problem could be solved with using the USB stick instead of direct transfer from Lightburn but it didn’t eliminate the freezing.

Can it be faulty files from LightBurn after an update?

Thanks for the patience!

I made a couple of videos about the issue:
FabCore - Job Fails 1
FabCore - Job Fails 2
FabCore - Job Fails 3

Try pulsing the laser before running the job.
→ Haven’t noticed much help from the pulsing, it even blocks the machine the same way
Try restarting the machine.
→ seemingly same effect as resetting the machine
Try disabling the laser, run the job and then turn on the laser. (Keyswitch)
→ when turning on the laser, it instantly stops, with the same behavior

In terms of # of devices in the power circuit, when I was testing, only the FabCore and some lights were on, nothing else.

Also for the followup questions
→ This happens for any job, high power, low power, you name it.
Do you have any UPS? Uninterruptible power supplies?
→ Nope

If this would indeed be a power supply issue, how would I need to test this and/or handle it?

I have some old computer power supplies if it would help :yum:

Hi Robin,

If the job runs fine with the laser PSU disabled then Its possible the PSU needs to be replaced.
A laser power supply is a little different than a computer power supply :wink:

Try running the machine on a different power circuit,

@rene.cortis if you are getting weird lines and cutting results and freezing, it could be a controller issue instead of a power supply problem.

Are their particular jobs which cause the problem. We have experienced a job copying over weird, resaving the file and it was fine after. I think taking the USB stick out quickly / not safely removing hardware can do that.