Solved?: Smoothieboard restarting

I read a few entries saying that the smoothieboard is disconnecting the first time the laser is fired. This got worse after I replaced the laser tube with a new one. As there is no easy way to replace the board right now we were trying different things to avoid this. Suprisingly starting the laser with zero power helped a lot. We are working with lightburn and this is our solution now.
In the preferences for the machine enter the following gcode before the start:

G00 G17 G40 G21 G54
; Start something

This will just draw a square with 5mm at zero power and will return to the point were it originaly was started.
This helped for me.


That’s awesome! I have the problem since ages and even exchanged the smoothieboard to no avail. I’ll definitely give this a try.
Many thanks for sharing!

Edit: Works great! Thank you!

Nice solution … I should have known this solution a few months ago.

1 Like

If I may ask: Where and how exactly do I enter those lines of code? I tried to find it myself, but had no luck so far. :thinking:

Lightburn -> Edit -> Device settings

Thx. I see you got the FabKit, I got the FabCore. On the FabCore this option is missing, think it’s because it got a Ruida board. But i too got the Problem that the laser moves to the place where it should start burning ant then freezes there, so i need to reset the machine and then it works. so i think it is not related to smoothieboards only.
I tried to set a small box with zero laser on the drawings top left corner, where the laser home is, with 0 power, and it seems to work too, but your solution is more “fire and forget” :wink: