Having strange issues with my FabKit lately

I am having weird issues with my (one of the earliest) FabKit lately.

The Y movement of the gantry is inconsistent and makes a weird noise, and when the motors are on and I try to jiggle the gantry, the right hand side requires a lot of strength to move, but the left hand is pretty easy to jiggle. (And I tested: The motor axle actually moves, so it’s not a lose gear wheel)

Also, the laser tube doesn’t seem to be firing at the same power consistently. When I try to engrave a single rectangle at pwr/spd 25%/60, most of the time it burns clean through a 3mm plywood sheet, but sometimes it doesn’t, and when it doesn’t, the purplish plasma ‘beam’ in the tube is significantly dimmer than the other times…

Here’s a few examples of how inconsistent it appears:

<-- that line under the D should be straight!
(NOTE: These images are rotated 90° clockwise!)

Any thoughts? Could the Smoothieboard be on it’s way out?

That’s a strange combination of problems. Did you check for bad (power) connection?

Yeah… Power seems to be fine… Connections appear fine as well, I removed and reseated plugs, etc., but no difference…

It looks like there is some slippage on the head (X axis) as well, because of the inconsistent lines, but that might also just be a timing issue, although I’d expect it to be more ragged in that case, and not a small shift in one or the other direction for a number of mm’s…

Have you checked all cooling pipes for kinks?
The sound is like metal scratching on metal.
Points to check:
-the screw in the gantry that triggers the y-limit switches
I have a MK6. Which version is yours and is the y-axis driven by one or 2 motors?

Mine’s a Mk2 (Mk1 was never an actual product, so for all intents and purposes, it’s the 1st gen that was delivered to customers, right after the failed kickstarter) with 2 motors on the Y. (And 1 on X, 1 on Z)
All limit switches work fine, and the gantry is moving smooth when manually moving it with power off… It seems to be only the left motor that is having problems, as noted, because - with motors engaged - I need “a lot” of muscle power to move the right hand side of the gantry, whereas the left hand side is very easy to move!

The cooling is fine, and it’s not the gradual variation you can see when there are cooling issues… It’s literally 8-15 lines full power, 1-2 lines dimmed, and then back to full power… I tried to record it, but it’s almost impossible to see on video, because the camera keeps adjusting all the time!

Hmm. I had to fix a scratching of a motor pulley against a bearing holder in mine. But the MK6 uses 1 motor for the y-axis, so that is not directly comparable. But look for any parts that might touch and shouldn’t, like belt pulley against motor/housing etc. (guessing from the sound in the video).
EDIT: or maybe the tension pulley?

I can move the gantry without any issues or sounds when the motors are not engaged, so nothing is grinding against anything else. The tension on the belts is the same on both side, and hasn’t significantly changed (aside from any possible stretching in the belt) and the shellac I’ve put on the screws is still in place, so I am certain the screws did not rotate by themselves either

There is no visible/audible damage anywhere, as I can move both head and gantry the whole range without any issues when power is off…

I am considering swapping the two Y motors, to see whether the issue moves along… (If it does, it is definitely the motor gone bad… If it doesn’t, I am really suspecting the Smoothie Board…)

1 Like

I agree. Next logical step is swapping the motors. From what you have written so far, my guess would be a defective motor. (maybe one of the internal bearings)

1 Like

In fact I have sort of the same problem (also MK2) with the left Y motor. It randomly falls in ‘neutral’ gear, and is easy to move. It’s hard to finish a job properly. First I thought it was bad connection, but it isn’t.

Really? That’s weird… I have stuff to do, but hope to squeeze in some time to swap the two motors to test…

I’ll update here when I’ve tested it!

I swapped the SD card with a brand one, upped the power on the Y steppers to 1.9A and finally swapped the plugs for both on the SmoothieBoard (of course testing in between)

I expected the last step to either do nothing at all, or move the issue from left to right, however the issue dissappeared, and since then I haven’t seen it again. I then upped the minimum power for the tube from 0.02 to 0.03, and that seems to have resolved that issue, but in the past I have seen some scoring by the laser on ‘whitespace’ moves with that value, esp. on Acrylics, so I’m not certain that is a permanent fix…

2 Likes

This reads like hoodoo voodoo. Swapping was one of my thoughts, so I will try that one too.

I hope it works for you as well! :wink:

@CescoAiel
Sorry for not seeing the issue sooner, been busy delivering machines last week so people can get busy for Christmas :slight_smile:
Best to send a message to support@fabcreator.com and I am sure to see it.

Sounds like the smoothies config file may have corrupted and failed to output the correct amp setting to the motor which is why replacing the SD card with a fresh file may have fixed it.

Mk1-Mk3 were all prototypes Mk4 was the first to be delivered these were primarily from our kickstarter supporters. The Mk6 is a very different machine and larger machine.

I am planning to make a comprehensive upgrade for the Mk4 and the Mk5.
Basically a drop in replacement to upgrade the electronics from the old smoothie and interlock board to our new board and RD controller found in the Mk6.

@CescoAiel what temp is it?
running the laser with cold water will affect its performance.
It could also be a problem with the laser PSU as i believe we only change the tube when the last one froze?

@CescoAiel or perhaps the laser power issue was also corrected with a new SD card?

Mk4 then… It was the first run of “kickstarter” devices…

I’m not certain I would prefer an RD controller, as I know what I can do with the Smoothieboard or other gCode compatibles…
One of the things my custom start/stop script does is fire up the air-extraction, then wait a bit, before starting the normal code, and at the end it waits 30 seconds before turning off air-extraction, just to ensure the work area is as free of smoke as is feasible…
I’m not certain I can do that with the RD controller?

(Which also reminds me that I still have to mount the connector for the rotational unit, so I can finally start testing that as well Just too busy with too many things!)

As for the laser PSU: We indeed only changed the tube, and not the PSU, but right now it seems to be working as expected, so I’m assuming it was an issue with the SD Card. I’ve read that sometimes the board cannot correctly read it on startup, even if the USB Drive access has no issues. So I am hoping/assuming that the SD card swap did the trick, but will keep an eye on the performance. I have an aquarium heater in the cooler that I turn on when the water is too cold, until I hear the cooler kick in, at which point I turn off the heater and let the laser take over the task of heating up the water! :wink:

1 Like

:smiley: indeed it was :slight_smile:
Below is what you could call the Mk1 of our laser cutter.

Then came the first original FabKit which was on kickstarter

after the ks did not succeed we merged the Fab40 and FabKit to make the FabKit you have now.
However there were a few steps on the way that :smiley:

The first one still using a Raspberry pie and touch screen

Then we switched to use a pipo windows 10


Then we get to the machine you have :smiley: The Mk4 we call it.


Then came the Mk5 which was basically lots of little changes and no real change to specs in comparison to the mk4.

Which brings us today with the Mk6 which is a bigger machine with up to 75w larger and faster motors and a Rudia controller interface. Sadly no longer opensource on the software side but the frame etc will remain so.

A friend of ours is working on an opensource controller using GRBL, no eta on that.

The start stop and or 10v control for the fan or filter depending on your set up can certainly be done with the RD controller and a timed relay for example.
We already upgraded on FabKit mk5 to the RD controller and also added a timed relay for the fan he had.

Rotary is also possible with the RD, however we still dont have alot of experience with rotaries. However Lightburn has lots of documentation with RD controllers and rotaries etc.

Sounds like maybe it was the SD card causing both problems. Let me know if you start experiencing them again.

If you do ever need to upgrade/replace the controller and want to keep a smoothie based machine there are lots of clones in china, however I would recommend breaking out the stepper drivers as the boards we tested had lots of issues with the onboard ones.

Yeah… Clone Smoothies are notoriously bad on the drivers…

What are the benefits of a Rudia controller?

I obviously would need 5 axis controllers (X-Y-Y-Z-A) and at least 2 more outputs for the air compressor and extraction… I would hate to have to work with external timer relays for the extraction though…

Essentially stability and reliability. Easier interface to manipulate the machine.
Faster engraving potential as it has a better code for rastering.
However if your smoothie is still working fine then no need to change.
Its 4 axis XYZU the Y can be used to drive 2 stepper drivers no problem.
There are outputs for air compressor and extraction etc. we have made our own PCB to break out the board and do the LEDs and security etc

We dont have a control for the external fan as default, we tend to recommend leaving it on while you are using the machine. so a timer relay din mounted etc is an easy fix.